High API load leading to errors
Incident Report for Rhumbix
Postmortem

This morning Rhumbix experienced about an hour and a half during which our services were partially degraded. We have identified that the downtime was caused by unusual usage of our public API by multiple customers simultaneously. The downtime has been resolved after 1.5 hours and we are working with these customers to transition them to our recently released public API v3. API v3 provides a way to interact with Rhumbix without risking this kind of impact. We are also investigating changes we could make to our API to prevent similar downtimes in the future for customers using the older API.

Posted Nov 30, 2021 - 13:50 PST

Resolved
High load on our API endpoints is causing errors for some customers.
Posted Nov 30, 2021 - 04:26 PST